[dkim-dev] dkim-milter with postfix not working

Muzammel Asghar muzammel.linux at gmail.com
Sat Mar 13 12:33:17 PST 2010


hi Guys i am using dkim-milter with Postfix on fedora platform. I tried to
configured it but its not working. Here below detail.

dkim-milter-2.8.3-4.fc12.i686
postfix-2.6.5-2.fc12.i686

dkim-milter.conf contains below

BaseDirectory           /var/run/dkim-filter

Domain  test-xxx.mycompany.com

InternalHosts /etc/mail/dkim-milter/internal_hosts

KeyFile  /etc/mail/dkim-milter/keys/test-xxx.mycompany_default.key.pem

MilterDebug     2

PidFile         /var/run/dkim-milter/dkim

Selector                MY-selector

SignatureAlgorithm      rsa-sha1

SubDomains              Yes

Syslog   Yes

SyslogFacility  mail

SyslogSuccess           Yes

TemporaryDirectory      /var/tmp

UserID dkim-milter:dkim-milter

X-Header    Yes

Start dkim-milter by below command

/usr/sbin/dkim-filter -u dkim-milter -x
/etc/mail/dkim-milter/dkim-filter.conf -p inet:2020 at localhost

netstat -taunp | grep 2020
tcp        0      0 127.0.0.1:2020              0.0.0.0:*
LISTEN      30585/dkim-filter


Use below at the end of postfix main.cf for enable milter.

smtpd_milters = inet:localhost:2020
non_smtpd_milters = inet:localhost:2020
milter_protocol = 6

When i try to send mail, it gives below error in mail.log

Mar 13 20:16:34 malli dkim-filter[30585]: 95B882A102 "DKIM-Signature" header
added
Mar 13 20:16:34 malli postfix/qmgr[12776]: 95B882A102: from=<
muzi at test-xxx.xxx.com>, size=574, nrcpt=1 (queue active)
Mar 13 20:16:35 malli postfix/smtpd[31620]: disconnect from xxxxx.dsl.net
[x.x.x.x]


Mar 13 20:16:40 malli postfix/smtpd[31639]: connect from unknown[127.0.0.1]
Mar 13 20:16:40 malli postfix/smtpd[31639]: fatal: host/service
localhost/2020 not found: No address associated with hostname
Mar 13 20:16:41 malli amavis[6550]: (06550-16) (!)FWD via SMTP: <
muzi at test-xxx.xxx.com> -> <muzi at test-xxx.xxx.com>, 451 4.5.0 From
MTA([127.0.0.1]:10025) during fwd-connect (Negative greeting:  at (eval 96)
line 596, <GEN15> line 738.): id=06550-16
Mar 13 20:16:41 malli postfix/master[12773]: warning: process
/usr/libexec/postfix/smtpd pid 31639 exit status 1
Mar 13 20:16:41 malli postfix/master[12773]: warning:
/usr/libexec/postfix/smtpd: bad command startup -- throttling

I not get any clue why its not working. Kindly plz suggest where i wrong, i
am pretty much sure the error casue is that line as per above logs

Mar 13 20:16:40 malli postfix/smtpd[31639]: fatal: host/service
localhost/2020 not found: No address associated with hostname

But above dkim add the header and i think in processing reject , i dont know
why, please give guide lines and suggestions.

Thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://mipassoc.org/pipermail/dkim-dev/attachments/20100314/07d694cf/attachment.html 


More information about the dkim-dev mailing list